Paul C. Buff, Inc. Technical Forum

Technical Discussion Forum for all Paul C. Buff, Inc. Products

Login | Register

Active topics
 Topics   Replies   Views   Last post 
No unread posts New DigiBee 400 and 800 now available for order!

[ Go to pageGo to page: 1, 2 ]

Technical Support   Wed Jul 20, 2016 12:44 pm

16

1830

Mon Jan 23, 2017 1:39 pm

gridTop View the latest post

No unread posts Old flash question

bcraun   Mon Apr 24, 2017 12:53 pm

0

5

Mon Apr 24, 2017 12:53 pm

bcraun View the latest post

No unread posts Einstein modelling light as a continuous light source

irinag   Sun Apr 23, 2017 8:42 am

1

31

Sun Apr 23, 2017 3:09 pm

DuboisPhotoGrp View the latest post

No unread posts Adding handle to an Alien Bee

Freerojo   Sat Apr 22, 2017 8:17 am

0

24

Sat Apr 22, 2017 8:17 am

Freerojo View the latest post

No unread posts Should I replace my flashtube? -db800

mando   Thu Apr 20, 2017 2:29 pm

2

42

Fri Apr 21, 2017 9:42 pm

mando View the latest post

No unread posts use Vagabond Mini to power edgertronic high speed camera

tfischer   Wed Apr 05, 2017 6:58 pm

3

122

Thu Apr 20, 2017 4:37 pm

Technical Support View the latest post

No unread posts Cyber commander

AndyMonster   Thu Mar 09, 2017 4:25 pm

3

252

Thu Apr 20, 2017 4:32 pm

Technical Support View the latest post

No unread posts Dropped AB 1600

Eddie Maloney1981   Tue Apr 18, 2017 10:25 pm

1

43

Wed Apr 19, 2017 9:10 am

Technical Support View the latest post

No unread posts VML trouble

bazmaz   Tue Apr 18, 2017 3:25 pm

1

29

Wed Apr 19, 2017 9:06 am

Technical Support View the latest post

No unread posts CyberCommander turns off and resets lights when in "all"

LenShot   Fri Apr 14, 2017 6:42 am

1

67

Mon Apr 17, 2017 3:32 pm

Technical Support View the latest post

No unread posts Frosted glass dome on Einstein broken

Wanderer47   Sat Apr 15, 2017 7:54 am

1

45

Sat Apr 15, 2017 11:36 am

Technical Support View the latest post

No unread posts Alien bee 400 not working

vanessarocha   Tue Mar 07, 2017 11:39 pm

2

190

Thu Apr 13, 2017 1:59 am

vanessarocha View the latest post

No unread posts New Digibee 800 Hot problem

vcap   Sun Apr 09, 2017 7:51 pm

1

74

Mon Apr 10, 2017 11:00 am

Technical Support View the latest post

No unread posts How to get the Einstein to REMAIN in ACTION mode

WestonBoucher   Tue Apr 04, 2017 8:42 pm

1

112

Wed Apr 05, 2017 9:07 am

Technical Support View the latest post

No unread posts CC Spec Lights

mwoodbury   Tue Apr 04, 2017 9:42 am

1

99

Tue Apr 04, 2017 12:44 pm

Technical Support View the latest post

No unread posts melted flash tube tip, questions

gridTop   Sat Apr 01, 2017 4:57 pm

2

124

Mon Apr 03, 2017 8:15 pm

gridTop View the latest post

No unread posts New Product for Outdoor Photographers

[ Go to pageGo to page: 1, 2 ]

capturedconnections   Mon Sep 28, 2015 4:52 pm

10

2876

Mon Apr 03, 2017 1:33 pm

RDKirk View the latest post

No unread posts Yikes, cat pee on my medium softbox. Cleaning Ideas?

javapop   Mon Mar 20, 2017 1:44 pm

2

188

Mon Apr 03, 2017 1:30 pm

RDKirk View the latest post

No unread posts Diffusion Filters

KarenG   Wed Mar 29, 2017 2:23 pm

1

145

Thu Mar 30, 2017 9:32 am

Technical Support View the latest post

No unread posts Need to replace with Bowens mount

mnhim001   Tue Mar 28, 2017 3:24 pm

1

132

Wed Mar 29, 2017 9:08 am

Technical Support View the latest post

No unread posts Modifier stuck on Einstein

purple larry   Mon Mar 27, 2017 2:21 pm

1

128

Wed Mar 29, 2017 9:08 am

Technical Support View the latest post

No unread posts How to do HSS with Einstein+Canon5Dmark3?

Serena   Fri Mar 03, 2017 7:27 am

6

488

Tue Mar 28, 2017 10:26 am

nogreymatter View the latest post

No unread posts Trouble with Flash

Snapshots14   Mon Mar 27, 2017 10:28 am

1

127

Mon Mar 27, 2017 9:29 pm

Technical Support View the latest post

No unread posts Will hot shoe adapter HSA fit Sony a6300, a6500?

reimus   Sun Mar 26, 2017 3:33 pm

1

107

Mon Mar 27, 2017 9:07 am

Technical Support View the latest post

No unread posts Alien Bee 800, "OK" and "DUMP" lights never come on

Zzini   Thu Mar 23, 2017 8:06 pm

1

139

Fri Mar 24, 2017 3:59 pm

Technical Support View the latest post

 

 Forum   Last post   Topics   Posts 
No unread posts Technical Discussion

This forum is for your technical questions that have not been answered in the FAQs above. Please limit questions and answers to technical issues.

Mon Apr 24, 2017 12:53 pm

bcraun View the latest post

3555

19950



All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


Jump to: