Paul C. Buff, Inc. Technical Forum

Technical Discussion Forum for all Paul C. Buff, Inc. Products

Login

Post a reply
 [ 4 posts ] 

Tue Nov 15, 2016 6:47 pm

Joined: Tue Nov 15, 2016 6:40 pm
Posts: 1

I've had this light for over 5 years now. Last few years it was in storage. Today I tried to use it and it's a no go. I plugged it in. The fan is working, but I am not able to fire it; no modeling light, no green light in the back. Sounds like it needed to go for repairs from what I've read so far. Any idea how much is repairs or should I get a new one?




Top Top
Profile
 

#

Wed Nov 16, 2016 12:56 pm

Site Admin
Joined: Tue Dec 08, 2009 10:43 am
Posts: 5266

Repairs start at $35, plus shipping. Worst case is $97. Up to $80 is assumed to be authorized. Anything over $80, they will call you before they continue. The prices do not include flash tubes or model lamps or shipping.

Ultimately, repair would almost certainly be considerably cheaper.




Top Top
Profile
 

#

Fri Dec 02, 2016 12:33 pm

Joined: Fri Dec 02, 2016 12:32 pm
Posts: 1

Did you find out what was wrong with your AB? Mine is doing the same thing. Thank you!




Top Top
Profile
 

#

Fri Dec 02, 2016 12:40 pm

Site Admin
Joined: Tue Dec 08, 2009 10:43 am
Posts: 5266

scrop86 wrote:
Did you find out what was wrong with your AB? Mine is doing the same thing. Thank you!



does the light fire from its own test button?

Does the light fire from the receiver's test button?

Are you getting a green ready light?




Top Top
Profile
 
Display posts from previous:  Sort by  
Post a reply
 [ 4 posts ] 

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: Google [Bot] and 21 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum


cron