Paul C. Buff, Inc. Technical Forum

Technical Discussion Forum for all Paul C. Buff, Inc. Products

Login

Post a reply
 [ 3 posts ] 

Tue Mar 07, 2017 11:39 pm

Joined: Tue Mar 07, 2017 11:35 pm
Posts: 2

Hi everyone, my Alien Bee 400 does not stay on, it does work when I take a picture, but the light does not stay on the whole time, even when I have the ON button pressed...has anyone experienced this? Thank you in advance!




Top Top
Profile
 

#

Wed Mar 08, 2017 8:40 pm

Site Admin
Joined: Tue Dec 08, 2009 10:43 am
Posts: 5266

There are two sources of light, the model lamp, and the flash tube. The red power switch turns the whole unit on, and that should stay in the ON position until you turn it off.

The white ON button is for the model lamp only. If the model lamp does not come on, then the bulb may not be present (it screws into the socket), or the bulb may be a bad bulb (like any lightbulb can be). These bulbs can be swapped with any other household bulb (except CFL bulbs) so ensure the socket is working.

Also, be sure nothing is in the REMOTE jack on the light.




Top Top
Profile
 

#

Thu Apr 13, 2017 1:59 am

Joined: Tue Mar 07, 2017 11:35 pm
Posts: 2

Thank you so much! I'll try that!




Top Top
Profile
 
Display posts from previous:  Sort by  
Post a reply
 [ 3 posts ] 

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 14 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum


cron