Paul C. Buff, Inc. Technical Forum

Technical Discussion Forum for all Paul C. Buff, Inc. Products

Login | Register

Post a reply
 [ 3 posts ] 

Thu May 11, 2017 4:17 pm

Joined: Thu May 11, 2017 4:10 pm
Posts: 2

Lightly used Einstein that worked fine when tested a couple months ago now shows only a solid white screen when I power the unit on. Nothing to see on the back display panel but white blankness.

Was not doing an update or anything, just turned it on and found this. The bad new is that we have two large dance studios to photograph next weekend - ugh!!!!!!!!!!!!!!!!!!!!!!

The flash will fire with the test button and the menu/arrows are doing stuff in response to pushing those buttons, but the screen is just blank.

Any thoughts, ideas, tips, or other help is most appreciated. My bp is way high right now! :-(

Eric in FL




Top Top
Profile
 

#

Fri May 12, 2017 8:48 am

Site Admin
Joined: Tue Dec 08, 2009 10:43 am
Posts: 5243

Ultimately, the light will need to be sent in for repair. You may contact our repair department for turnaround times and what options may be available in the interim.

If you are in a must-use situation, you can get the light back to a known state by pressing the Easy Set button. This will take the flash and model lamp down to minimum, tracking, both recycle indicators, color mode, CH1, FQ1, and slave eye on. Careful counting and deliberate pressing of the function and arrow buttons can lead to accurate settings changes. Once the parameters are set, power up and down would be relative, but easy to change.



_________________
TS
info@paulcbuff.com
1-800-443-5542
https://www.facebook.com/paulcbuffinc
https://instagram.com/paulcbuffinc
https://www.youtube.com/c/paulcbuffinc
https://twitter.com/paulcbuffinc


Top Top
Profile
 

#

Fri May 12, 2017 11:55 am

Joined: Thu May 11, 2017 4:10 pm
Posts: 2

That's what I feared.
Just ordered a rush replacement this morning and it will arrive before we start dance studio season next weekend. I'll be sending that flash in a month or so when we slow down a bit!
Thanks!




Top Top
Profile
 
Display posts from previous:  Sort by  
Post a reply
 [ 3 posts ] 

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: Bing [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum


Search for:
Jump to: